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Getting Help 

 
This guide provides information only about how to install your 

Terrasolid products and licenses.   

 

We are sure that you will experience different problems with GeoCue, 

or Terrasolid products that range from installation issues to defects that 

made it through our testing undetected.  We hope that you will 

immediately contact us with any problems or questions and have the 

patience to work with us through a successful GeoCue deployment. 

 

Please browse our online searchable knowledgebase and user forum for the answers to your 

questions prior to contacting us via e-mail or phone for assistance with, or comments about 

GeoCue, or Terrasolid products. 

 

Online searchable knowledgebase and forum for all our products: 

support.geocue.com 
 

E-mail: 

support@geocue.com 
 

Phone: 

+1-256-461-8289 
 

Just ask for Terrasolid Support and you will get connected with someone who can assist you.  

There is usually someone in the office between the hours of 0700 and 1800 CT, USA on 

weekdays.  Weekends are sort of hit or miss. 

 

Fax (always on): 

+1-256-461-8249 

 

  

 

mailto:support@geocue.com
mailto:support@geocue.com
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About this Document 
 

Welcome to GeoCue’s Installing Terrasolid Products Guide. This guide will discuss typical 

download, installation and configuration of the Terrasolid products, as well as provide 

troubleshooting and recommendations on those topics. 

 

For information on using the Terrasolid products, please refer to the applicable User Guide. 
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Introduction  

This note covers setting-up the Terrasolid products and should be reviewed by your IT staff prior to registering for the 

permanent licenses. 

Invoice  

Be sure to review your Terrasolid invoice to determine the exact products you purchased. Please take notice of the 

differences between the full products and the lite versions. For example, TerraScan and TerraScan Lite are different 

versions of the same product and have separate installation programs. Only one of the two product versions may reside 

on a machine at one time. Installing the incorrect product for your licenses will result in the product indicating that it has 

no license. 

 

About Terrasolid  OY 
 
Terrasolid software packages are used world-wide for airborne and mobile LIDAR data and image processing. Each 
package alone fills the requirements of their specific task. However, the best benefit comes from bundling different 
applications together and performing the whole work flow - data calibration, point classification, image processing and 
delivery product production - in one software environment. 
 

About GeoCue Group 
 

GeoCue Group is a software development and consulting services company with two major foci: 

¶ Complete LIDAR tools, workflows and consulting services for airborne and mobile mapping 

systems 

GeoCue Group is North America’s largest provider of products, training and consulting services for 

airborne and mobile LIDAR applications. We are the North American authorized distributor for 

Terrasolid OY, the purveyor of the world’s most widely used LIDAR production tools. We are also the 

parent company of QCoherent Software LLC, the world’s only plug-in LIDAR exploitation solutions for 

the ESRI ArcGIS desktop products. 

¶ Geospatial workflow management tools, OEM products and Systems Integration services 

Nearly all geospatial production companies today deploy a wide range of software tools in mixed 

workflows. Most companies have developed internal software and integration techniques to optimize 

their processing workflows. They invariably discover that continuing in this direction is both slow and 

rapidly becomes cost prohibitive. What started as a small, internal development to improve a 

particular workflow has grown into a logistically impossible to maintain nightmare. GeoCue Group 

offers a comprehensive geospatial integration framework as well as custom consulting services to 

assist you in integrating your existing workflows into a GeoCue managed system.  
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Downloading the Installation Packages  

Bentley MicroStation Based Packages 
Terrasolid products are MicroStation based packages (MDL’s) and will run on either the newer 64-bit MicroStation 

CONNECT Edition (10.00.00.25 or later), PowerDraft CONNECT Edition (10.02.00.39 or later), and Bentley OpenRoads 

Designer CONNECT edition (10.01.00.15) or older 32-bit MicroStation v08.05.xxx (2004 Edition: 08.05.xxx), 

MicroStation v8i (08.11.07.443 or later), Bentley PowerCivil v8i (country versions 08.11.07.428 and 08.11.07.494), 

Bentley Map v8i and Bentley Map PowerView v8i (08.11.07.425, 08.11.09.91, 08.11.09.503). The licenses are the same 

for all versions of MicroStation, but the installation packages are different between the v8, v8i, and CONNECT Edition 

packages. The latest update for either of the 64-bit MicroStation, PowerDraft, or OpenRoads Designer CONNECT Editions 

are recommended as the new tools and feature enhancements are only in the CONNECT edition packages.  

1. Visit the Terrasolid download page at the following link: 
https://www.terrasolid.com/ssl/download_software.php  

2. Select the Start Download Button. 
3. Select the Language for the software (English or Finnish) 
4. Click on the appropriate software versions running on top of Bentley product. If License Server/Manager, 

TerraSlave, or TerraStereo is desired then select Stand-alone versions.  Select the appropriate Bentley platform. 
 

 
Figure 1 - ¢ŜǊǊŀǎƻƭƛŘΩǎ Language and Platform Selection 

https://www.terrasolid.com/ssl/download_software.php
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5. Select the products that you have purchased. 

 
Figure 2- ¢ŜǊǊŀǎƻƭƛŘΩǎ MicroStation Based Product Selection 

6. Once you select continue you will be taken to an information page, where you will need to enter the appropriate 
information. 

7. Once submitted Terrasolid will send a confirmation e-mail with a download link to the provided address. 
8. The packages will download as a single compressed file, typically named “Terrasolid_Applications.ZIP”. 
9. The installation folder for each selected application is now delivered as a zip file. All selected applications (zip 

files) are packed into a single zip file for download. This speeds up the download process. You need to unzip the 
download file first, and then unzip the application folder(s) in order to run the installation. 
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Microsoft Windows Based Packages 
Note: The packages on this page run on a machine running a Microsoft Windows operating system. These packages do 

not require any version of MicroStation to be installed. 

1. Visit the Terrasolid download page at the following link: 
https://www.terrasolid.com/ssl/download_software.php  
 

2. Click on an option in the Stand-alone applications for 32-bit or 64-bit Windows; in English only section. 
 

  

Figure 2 - TerrasolidΩǎ Microsoft Windows Based Product Selection Page 

3. Once you select continue you will be taken to an information page, where you will need to enter the appropriate 
information. 

4. Terrasolid will send you a confirmation e-mail with a download link to the provided address. 
5. The packages will download as a single compressed file, typically named “Terrasolid_Applications.ZIP”. 
6. The installation folder for each selected application is now delivered as a zip file. All selected applications (zip 

files) are packed into a single zip file for download. This speeds up the download process. You need to unzip the 
download file first, and then unzip the application folder(s) in order to run the installation. 

 

  Note: It is not necessary to install TerraSlave on a machine running TerraScan as 

the TerraSlave install is included with the installation of TerraScan. 

https://www.terrasolid.com/ssl/download_software.php
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Installing the Products  
1. After downloading the Terrasolid product(s) that you have purchased, please install the desired product(s) on 

each workstation that will be using the software by running the “Setup.EXE” located in the extracted product 
folder. I.e. “\tscan_ce_eng_018_006\setup.exe”. 
 
 
 
 
 
 

 

2. For pooled licenses install the Terra License Server, and Terra License Service (if desired) on the designated 
license server machine, and the Terra License Manager on each one of the client (workstation) machines. 64-bit 
recommended. 
 

          

Terra License Server and Terra License Manager are applications, which are communicating with each other 

through the Windows Pipe. In the system, Terra License Manager is used to load and return the licenses from 

the license pool. Loading an application does not automatically load the license from the pool folder.  

This communication method does not use the Internet, therefore, TCP/IP settings do not have any effect. If you 

would like to share the licenses through the Internet, please install a VPN, or use fixed Internet connections. For 

more information about Windows Pipe, please search on the Internet. The pipe is valid if you can open and save 

files to terra\pool018.  

Terra License Server Service is a service version of the License Server. It runs in the background without a user 

interface and does not require a user to be logged in to the server machine. When the Service is installed, the 

Terra License Server will act merely as a user interface for viewing the status of the license pool and to register 

the server information. 

Note: The default installation folder for all products is for the MicroStation 

Connect Edition. You will need to provide the appropriate MicroStation or 

equivalent install folder if installing on another Bentley application. 
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3. For node-locked licenses it is not necessary to install the Terra License Server.  It is, however, advisable to install 
the Terra License Manager to monitor the licenses which reside on the machine. 
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Registering  Your Terrasolid  Products  

Pool/Network  Licenses 
Network licenses are only available to customers with a valid maintenance agreement for the software and allow for the 

licenses to be used on different computers. This is the recommended licensing mode. Before registering for pooled 

licenses the Terra License Server will need to have installed on the machine that is to be used as the Terra License 

Server. 

1. Launch Terra License Server. 
2. Select File->Server Information. 

 

 
 

 

 
3. Click “Open Web”  
4. Please have a copy of your Terrasolid Invoice with product serial numbers on hand. 

 

 
  

Figure 3 - Finding the server name and ID 
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5. Enter the appropriate information to complete your registration. 

 
a. Enter the Server name and ID as found on the server information page in step 2. 
b. Reason of Registration: 

i. Select New Registration if you’ve purchased for the first time or additional licenses for an 
existing server. 

ii. Select Move licenses… if you are requesting to move licenses from an old server to a new one 
and agree to delete all licenses from the old server. 

c. Licenses to Register: 
i. Register all our licenses to this Server will register all licenses from all offices to the server 

named herein. 
ii. Register only those licenses listed below if only registering some of your company’s licenses to 

this server. If you have numerous licenses and different locations, Terrasolid is flexible and can 
accept several different servers. Separate the licenses used on each server by listing either their 
serial numbers, or the Terrasolid invoice number during registration. 

d. In the Information for Terrasolid box enter your Terrasolid Invoice number. 



GeoCue Installing Terrasolid Products 

GeoCue – Installing Terrasolid Products                         9                                                                20 February 2018 
Copyright 2011-2018 
GeoCue Group, Inc. 

6. Terrasolid will send you your licenses directly. Please be sure that you can receive e-mails with ZIP file 
attachments from registration@terrasolid.com. If you do not receive your licenses within 48-72 hours of 
registering, please contact support@geocue.com so that we may assist. 

7. To assist with our records please let us know when you receive your permanent licenses.  
  

mailto:registration@terrasolid.com
mailto:support@geocue.com
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Node-locked Licenses 

Node-locked licenses are targeted to users who always use the licenses on the same machine, or for those evaluating 

the software. Before registering for node-locked licenses you will need to have the product(s) installed on each machine. 

1. Launch MicroStation and load the MDL for one of the Terrasolid products. 
2. The following license window will appear. Select the Request License button. 

 

3. For customers who have purchased licenses please have a copy of your Terrasolid Invoice with product serial 
numbers on hand. 

 

 
Figure 4 - Terrasolid Invoice Example 
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4. Enter the appropriate information to complete your registration. 

 
a. For purchased product licenses:  

i. Select all of the applications you wish to register on this machine; 
ii. In the “Valid Users” information box enter the serial numbers for each of the selected purchased 

products to register them to the same machine; 
iii. In the Information for Terrasolid box enter your Terrasolid Invoice number. 

b. For Evaluation licenses: Select all of the applications you wish to evaluate on this machine. 
5. Terrasolid will send you your licenses directly. Please be sure that you can receive e-mails with ZIP file 

attachments from registration@terrasolid.com. If you do not receive your licenses within 48-72 hours of 
registering, please contact support@geocue.com so that we may assist. 

6. To assist with our records please let us know when you receive your permanent licenses.  
  

mailto:registration@terrasolid.com
mailto:support@geocue.com
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Setting Up Your Terrasolid  Licenses 

Once you have received your licenses (*.LIC) you will need to follow the instructions for your license type. 

Node-locked Licenses 
1. For each application, start the application and then copy and paste the license information (User name and 

Code) from the provided RTF document into the License dialog. Verify the check sum value matches, and then 
click OK to create a license file (.LIC) in the Terra Applications installation directory, namely, “C:\terra\license”. 

 
2. Before using TerraSlave please refer to the Configuring TerraSlave section. 
3. You are ready to start using your Terrasolid software. 

Pool Licenses 
1. On the Terra License Server machine extract your licenses (.LIC) into the current license pool folder found under 

the Terra Applications installation directory, namely, “C:\terra\pool018”. 
2. Open the Terra License Server GUI: 

a. The licensed products should be listed in the top left hand pane and the licenses in the top right hand 
pane.  

b. Configure the Terra License Server by selecting File->Settings: 
i. Create an Access Code. The access code can be any alphanumeric sequence and is used to 

ensure that Terra License Managers are talking to the correct Terra License Server. 
ii. Set the max duration which is the maximum amount of time a license can be checked out from 

this Terra License Server by any Terra License Manager. 

 
3. Test the system by first loading the licenses using the Terra License Manager, which is installed on your server 

machine.  
4. On each client machine open the License Manager: 

a. Configure the Terra License Manager by selecting File->Settings: 

Caution: Keep the max duration (check out timeframe) short as licenses checked 

out are unrecoverable until they expire. 



GeoCue Installing Terrasolid Products 

GeoCue – Installing Terrasolid Products                         13                                                                20 February 2018 
Copyright 2011-2018 
GeoCue Group, Inc. 

i. Enter the Terra License Server name or browse to it.  Please note that browsing may take a long 
while to generate a list of all of the machines on the network. Enter the Access Code for the 
Terra License Server. 

 

 

b. To check out a license for a product on the machine: 
i. Click on each desired license type and then select License->Get from server: 

i. Select the License version to match the major version of the installed product. 
ii. Enter the expiration date for the license by either: 

1. Entering the date when the license expires (DD/MM/YYYY) or; 
2. Specifying the license check out duration in number of days. 

 

 

c. To check for available licenses on the machine: 
i. Click on each desired license type and then select View->Server State: 

 

Note: The max duration specified in the Terra License Server supersedes the 

duration entered in the Terra License Manager. 
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ii. Each License Type can be viewed individually by using the Information option: 
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Configuring TerraSlave  

Before using TerraSlave it needs to be configured so that it can find the applicable node-locked licenses or perform an 

automatic check out/in of floating licenses.  

TerraSlave ɀ Node-locked Licenses 
1. Browse to the TSlave installation folder found under the Terra Applications installation directory, namely, 

“C:\terra\tslave”. 
2. Double-click on TSlave.exe to launch the TerraSlave GUI. Note that the GUI will open minimized in the taskbar. 
3. Open the Licensing dialogue by selecting Help->Licenses 

 

 

4. Directory should be set to the Licenses folder in your Terra installation directory where the node locked licenses 
were placed, typically “c:\terra\license”. If not, browse to the folder to set it. 
 

 
5. Select OK. 
6. Close the TerraSlave GUI. 
7. After closing the TerraSlave GUI a TSlave.UPF file is generated in the TSlave installation folder. 
8. Repeat for each machine that has a node-locked license or copy the UPF file to the TSlave installation folder on 

each of those machines. 

  

Note: TerraSlave will utilize a TerraScan license if there are no available TerraSlave licenses. 
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TerraSlave - Pool Licenses 
1. On the client machine Browse to the TSlave installation folder found under the Terra Applications installation 

directory, namely, “C:\terra\tslave”. 
2. Double-click on TSlave.exe to launch the TerraSlave GUI. Note that the GUI will open minimized in the taskbar. 
3. Open the Licensing dialogue by selecting Help->Licenses 

 

 

4. Select the Use Terra License Server checkbox. 
a. Enter the Terra License Server name or browse to it.  Please note that browsing may take a long while to 

generate a list of all of the machines on the network. 
b. Enter the Access Code for the Terra License Server. 

 

 
 

5. Select OK. 
6. Close the TerraSlave GUI. 
7. After closing the TerraSlave GUI a TSlave.UPF file is generated in the TSlave installation folder. 
8. Repeat for each client machine or copy the UPF file to the TSlave installation folder on each of those machines. 

  

Note: TerraSlave will utilize a TerraScan license if there are no available TerraSlave licenses. 
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Personalizing the Configuration  

There are several different configurations that can be done with the Terrasolid products to allow more customer 

personalization. These include: 

¶ Hiding unused applications within the Terra License Manager; 

¶ Sharing Terrasolid configuration files across a network; 

¶ Setting up GeoCue to run TerraSlave using specific configuration files;  

¶ Configuring Terrasolid thread counts. 

Hiding Unused Applications  within License Manager  
1. Open License Manager 
2. Select all products that are not installed on the machine 
3. Select View Ą Hide Selected Applications 
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Sharing Terrasolid Configuration Files between  Users 
The instructions below are specified for use with the TerraScan product, but can be set-up to be used with any of the 

Terrasolid products. 

1. Using Microstation set-up TerraScan with all the projection systems, input and output formats, transformations 
and any other settings that might be needed for any given project. This information is saved in the Terra 
Applications folder, namely, “c:\terra\tscan” in the following files: 

a. Alrepfmt.inf – TerraScan Align Report 
b. Blocknaming.inf – TerraScan block naming formulas 
c. Codes.inf – TerraScan codes 
d. Collection_shapes.inf – TerraScan Collection shapes 
e. color_mixtures.inf – TerraScan Point Color Mixtures 
f. Outfmt.inf – TerraScan Output Formats 
g. Projection_Systems.inf – TerraScan Projection Systems 
h. Rail_sections.inf – Rail section templates 
i. Scanner_systems.inf – Scanner System definitions 
j. Section_templates.inf – Section templates 
k. Targets.inf – TerraScan Targets 
l. Tower_functions.inf – Tower Function definitions 
m. Tower_statuses.inf – Tower Status definitions 
n. Tower_types.inf – Tower Type definitions 
o. Trajfmt.inf – TerraScan Trajectory Formats 
p. Trans.inf  - TerraScan Transformations 
q. tree_species.inf – TerraScan Tree Species for tree database tools 
r. Tree_types.inf – TerraScan Tree Type definitions 
s. Waveform_profiles.inf – Waveform profile definitions for scanner systems 

2. Determine a place on the local network where these files will be placed. 
3. Create a folder. 
4. Set the permissions for the folder to read only for all users, or full control for one user and read only for the rest 

of the users. 
5. Place the files mentioned above in the folder. 
6. On a client machine go to C:\terra\config and open the TScan.CFG file 
7. Modify the TSCAN_SET location to point to the network folder.  

a. It is highly recommended to use a UNC path. 
b. Use forward slashes with three forward slashes at the beginning and two forward slashes for the rest of 

the address including the double forward slash at the end. For example: 
“TSCAN_SET=///MyPC//TerraScan_Test//” 

8. Place this TScan.CFG file on each client machine that is going to be using the custom configuration files. 

 

  

Caution: Settings are only loaded when MicroStation is first launched. Terrasolid 

now saves the settings each time the settings dialogue is closed. 

Tip: Replace the TScan.CFG and TScan.PTC files in the installation package prior to 

installing to make it easier to maintain and roll out your custom settings. 
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Using Terrasolid Configuration Files while Running TerraSlave from GeoCue 
These instructions are specific only to customers who are using the GeoCue software to run TerraSlave. 

1. Using MicroStation set-up TerraScan with all the projection systems, input and output formats, transformations 
and any other settings that might be needed for any given project. This information is saved in the Terra 
Applications folder, namely, “c:\terra\tscan” in the following files: 

a. Alrepfmt.inf – TerraScan Align Report 
b. Blocknaming.inf – TerraScan block naming formulas 
c. Codes.inf – TerraScan codes 
d. Collection_shapes.inf – TerraScan Collection shapes 
e. color_mixtures.inf – TerraScan Point Color Mixtures 
f. Outfmt.inf – TerraScan Output Formats 
g. Projection_Systems.inf – TerraScan Projection Systems 
h. Rail_sections.inf – Rail section templates 
i. Scanner_systems.inf – Scanner System definitions 
j. Section_templates.inf – Section templates 
k. Targets.inf – TerraScan Targets 
l. Tower_functions.inf – Tower Function definitions 
m. Tower_statuses.inf – Tower Status definitions 
n. Tower_types.inf – Tower Type definitions 
o. Trajfmt.inf – TerraScan Trajectory Formats 
p. Trans.inf  - TerraScan Transformations 
q. tree_species.inf – TerraScan Tree Species for tree database tools 
r. Tree_types.inf – TerraScan Tree Type definitions 
s. Waveform_profiles.inf – Waveform profile definitions for scanner systems 

2. Determine a place on the local network where these files will be placed. 
3. Create a folder. 
4. Set the permissions for the folder to read only for all users, or full control for one user and read only for the rest 

of the users. 
5. Place the files mentioned above in the folder. 
6. Open the GeoCue Client. 
7. Go to Setup Ą Options Ą LIDAR 1 CuePac 

a. On the Misc tab browse to the folder contains the configuration files to be used by TerraSlave when 
running macros. 

 

b. Click OK to accept the option 
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Setting the Thread Count  
The instructions below are specified for use with the TerraScan product, but can be set-up to be used with any of the 

Terrasolid products. 

1. Open TerraScan Settings 
2. Select Operation 
3. Under Processor Usage specify the Maximum Threads 

a. By default, this value is 2 
b. Maximum value can be set to 16 for 32-bit applications, and 128 for 64-bit applications. 
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Configuring TerraSlave for  GeoCue when Installed in a Location other than the Default  

By default, GeoCue is looking for the TerraSlave executable, TSlave.EXE, in the typical installation folder, 

“C:\Terra\TSlave”, where it is installed by either the TerraScan, or TerraSlave setup. The TSlave executable and user 

preference, UPF, file both need to be located within this directory. To create the UPF file see the Configuring TerraSlave 

section of this document. 

If TerraScan, or TerraSlave, is installed in a location other than the default then for each machine where this is the case 

make a registry entry to enable GeoCue to find the TSlave executable when needed: 

1. Create the applicable key for your operating system: 
a. 32-bit Operating System: HKLM\SOFTWARE\Terrasolid\TerraSlave 
b. 64-bit Operating System: HKLM\SOFTWARE\Wow6432Node\Terrasolid\TerraSlave 

2. Underneath that key, create a PathName string value; 
3. Set the value of PathName to the TerraSlave directory where the “tslave.exe” resides. 

 
 

 

  

file:///C:/Terra/TSlave


GeoCue Installing Terrasolid Products 

GeoCue – Installing Terrasolid Products                         22                                                                20 February 2018 
Copyright 2011-2018 
GeoCue Group, Inc. 

Troubleshooting  

Installing on Windows 7 , Windows  Server 2008 or later Operating Systems  
Note: It is necessary when installing the Terrasolid products on a machine running the Windows 7, Windows Server 2008 

or later operating systems to do so by right-clicking on the setup executable and selecting “Run as Administrator”.  

Program Compatibility Assistant Message  

Symptom: After the installation is complete a Program Compatibility Assistant message will appear: 

 

Probable Resolution: Select the option for “This program installed correctly” or simply select cancel. This is a benign 

message as long as the program was installed using administrative permissions and under an account with permissions 

to write to the install folder. If this is the case then the installation completed successfully. 

Terrasolid Package  Crashes in MicroStation  

Symptom: User notices that MDL crashes randomly within MicroStation. 

Probable Resolution: On Windows 7 and later operating systems it is necessary to install packages using the “Run as 

Administrator” option. Failing to do so may result in these random product crashes. Try re-installing by right-clicking on 

the Setup.EXE and selecting “Run as Administrator”. 

DLL Error Message Installing Software  

Symptom: User receives the following error messages when attempting to install the Terrasolid products. 

 

Probable Resolution: MicroStation and/or the product being installed is still open on the machine. Close MicroStation 

and any open sessions of the product, then retry the installation.   
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Unable to Check Out a License 

No Reply from the Server  

Symptom: User receives a message indicating there was “no reply from the server” when attempting to check-out a 

license using the Terra License Manager. 

Probable Resolution (Terra License Server GUI):  

Option 1: 

Verify that the Terra License Server GUI is open on the server machine. 

Option 2: 

Verify that the information entered in the License Manager under File->Settings is correct.  Perhaps there is a typo in the 

name of the server machine.  

Probable Resolution (Terra License Server Service):  

Option 1: 

Verify that the Terra License Server Service, called “TerraLicenseService015” is running on the server machine by 

opening the local services. 

 

Option 2: 

Verify that the information entered in the License Manager under File->Settings is correct.  Perhaps there is a typo in the 

name of the server machine. 

Option 3: 

The \terra\pool015\License_server.EXE on the server, and the \terra\license\license_manager.exe on the client must 

both be allowed to communicate through any firewalls. Add inbound and outbound exceptions to the firewall for both 

of these programs. 

Option 4: 

The user running the Terra License Manager must have domain level access permissions to the Terra License Server 

machine. 
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Option 5:  

Ping the server by name from the client. If there is a response then the machine name may not be resolving correctly for 

the Terra License Server. Modify the server name in the Terra License Manager to be the IP address of the Terra License 

Server machine. Then restart the Terra License Server Service, if applicable. If there is no response to the ping, resolve 

the basic connection issue between the two machines before doing further troubleshooting with the Terrasolid 

software. 

Option 6: 

Turn on Network Discovery for the Terra License Server machine, and if necessary, for the client machines as well. Refer 

to this link for more information from Microsoft on Network Discovery: 

http://windows.microsoft.com/en-us/windows/what-is-network-discovery#1TC=windows-7 

Bad Access Code 

Symptom: User receives a message indicating a “Bad access code” when attempting to check-out a license using the 

Terra License Manager. 

Probable Resolution: The message indicates that the client machine is not configured to have the same access code as 

the server. Verify the access code in Terra License Manager (File->Settings) on the client and in the Terra License Server 

(File->Settings) on the server. If running the Terra License Server Service be sure to restart the service after making any 

changes in the GUI. 

No Free License  

Symptom: User receives a message indicating there is “no free license” when attempting to check-out a license using 

the Terra License Manager. 

Probable Resolution: The message indicates that there are no more licenses available to check out from the server.  

Option 1: 

Users can verify license availability and which machines/users have licenses occupied by opening the Terra License 

Manager and looking at the server state (View -> Server State) and then selecting the desired package from the 

dropdown beside Information. The used licenses are subsequently listed in the dialogue. 

Option 2: 

The access code was changed under the Terra License Server GUI and the Terra License Service now needs to be 

restarted before the program will acknowledge the new access code. 

 

http://windows.microsoft.com/en-us/windows/what-is-network-discovery#1TC=windows-7
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No Pool Licenses Available  

Symptom: User receives a message indicating there are “no pool licenses” when attempting to check-out a license using 

the Terra License Manager. 

Probable Resolution: This message indicates that the license server configuration has not been completed or the client 

machine is experiencing difficulties communicating with the Server.  

Option 1: 

Generally, this error message results due to the fact that Terra License Server Service was installed on the machine, but 

never started. Go to services on the server machine and start the Terra License Server Service, 

“TerraLicenseService015”. If the service does not appear in the list make sure it was installed (see Pool Licenses) or 

ensure that the Terra License Server GUI is open if the desire is not to run the service. 

Option 2: 

The license (LIC) files for pool licensing must reside within the current version pool folder, for example “terra\pool015”, 

on the Terra License Server machine and the user requesting the license must have as a minimum read & execute 

permissions on this folder. A user may browse to the folder to verify access and permissions. Ensure that license files 

provided by Terrasolid are unzipped into this folder. 

Nothing happens to the current expired or invalid status of a Pool License  

Symptom: User attempts to renew a license that is currently showing as expired or invalid and receives no new message 

and yet the expired or invalid status remains. 

Probable Resolution: This indicates that the current license in the folder is likely a temporary license or one of a 

different version than what is being checked out. Rename or move those licenses into a subfolder, re-open Terra License 

Manager and then attempt to check out the license once again. 
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Invalid License  

Symptom: User receives an error message indicating the licenses that were checked out are invalid. User may not be 

able to return the license to the license pool. 

Probable Resolution: This message indicates that there is a problem with the installation of the Terra License Manager. 

Option 1: 

This error message can result if the Terra License Manager executable was copied from another computer instead of 

being installed on the machine in question. Install Terra License Manager on the client machine and verify that the 

licenses are now listed as valid. 

Option 2: 

This error message can also result if the Terra License Manager software was not installed with full administrative rights 

on Windows 7 era, and later, operating systems. Re-run the installation executable by right-clicking on "Setup.exe" and 

selecting the "Run as Administrator" option. After re-installation verify that the licenses are now listed as valid. 

License Window Appears when Loading a Product  
Symptom: When loading the Terrasolid MDL within MicroStation the license dialogue appears and stays on top. 

Probable Resolution: The license dialogue appears when first loading the product if the product does not have a valid 

license. 

Option 1: 

Verify that the major version of the product installed on the machine matches the major version of the license. This 

means that if you are running v015.x software you need to have v015 licenses on the machine. 

Option 2: 

Verify that the license on the machine is for the same package as what was installed. A “Lite” license cannot be used to 

run a full version of a product and vice versa. 

Option 3: 

Products run from the \terra\ma folder operate using licenses located within the \terra\license folder. If you have both 

MSv8 and MSv8i installed on the machine be sure that the licenses are checked out for each version by running the 

Terra License Manager from within each of the license folders. For instance, “\terra\license” and “\terra_v8i\license”. 

 

 


