InstallPyYAML: Requirement Already Satisfied

Problem:

Trying to run the Create Orthomosaic from Photo Package keeps prompting the user that, “Additional Python components are required. Run: ..\installPyYAML.bat”.

Prompt to run installPyYAML.bat

However, that has been run already and running it again states, “Requirement already satisified: …in c:\users\%username%\appdata\roaming\python…”, where %username% is the Windows login of the user that ran the installPyYAML.bat the first time.

Probable Resolution #1:

Delete the c:\users\%username%\appdata\roaming\python…” folder, where %username% is the Windows login of the user that ran the installPyYAML.bat the first time. Then, install the batch file again, ensuring to use the administrative console (elevated command prompt):

  1. Open an elevated command prompt by right-clicking on the Command Prompt in the Start menu and selecting “Run as Administrator”.
  2. Change directory to the appropriate MSPy folder, using “cd C:\Program Files\Common Files\LP360\MSPy” (Metashape v1.6.5 or 1.6.6) or “cd C:\Program Files\Common Files\LP360\MSPy38” (Metashape v1.7.x).
  3. Execute the batch file by typing “InstallPyYAML.bat”, <Enter>
  4. You may see a notification about a newer pip version being available, but can ignore this message.
Ignore message about newer pip
Share

GeoCue Group Support has written 889 articles

Leave a Reply